Author Topic: Zombies walking in place (moar halp plz)  (Read 369 times)

0 Members and 1 Guest are viewing this topic.

Offline kaizokuroof

  • *
  • - Original Poster (OP) -
  • Rotting Walker
  • Posts: 53
  • Country: au
  • Respect: 3
    • View Profile

Zombies walking in place (moar halp plz)

« on: November 08, 2016, 10:46:01 pm »
Hey buds, I'm back again for more help. Everything has been going swimmingly, I've made a couple test maps with very bad detailing etc, to learn the ropes and fixed most of my issues a long the way.

This time however, i've followed all my previous ways to do things, put a lot of effort into the map, layout design and game play, but now it's come time to add the zombies in and I'm having issues.

I've taken some screenshots, in game and both in the editor.

This is taken from the window they're meant to run to.

The barrier is named thusly: start_zone_window1
It is copied and pasted from the one that starts in the map.
The zombie spawner is pointing to the correct zone spawner, the kvp "script_string" in the struct is set to start_zone_window1
There is no clipping stopping the zombie from accessing it. The barrier is floor height, so the zombies should be able to reach it.
 


Here is the in game editor


and another one for the map (lower)



Could it be that my map is raised off of the ground? It's still well within all the boundries, as I dared not to mess with that. Any help would be appreciated.

If it is caused by the map being in the sky, any assistance moving my entire map down would be cool too. none of it is prefabed so each room is part of that same layer.


Offline kaizokuroof

  • *
  • - Original Poster (OP) -
  • Rotting Walker
  • Posts: 53
  • Country: au
  • Respect: 3
    • View Profile

Re: Zombies walking in place (moar halp plz)

« Reply #1 on: March 20, 2017, 01:54:42 pm »
Bumpity bump. Can I supply anything else that might be able to assist with people helping me?

I can upload my map file if that'd help?
« Last Edit: March 20, 2017, 02:02:03 pm by kaizokuroof »

Offline kaizokuroof

  • *
  • - Original Poster (OP) -
  • Rotting Walker
  • Posts: 53
  • Country: au
  • Respect: 3
    • View Profile

Re: Zombies walking in place (moar halp plz)

« Reply #2 on: March 21, 2017, 10:44:12 pm »
Hey guys,

I fixed it :) Not only did I move my map and all the scripts into a "New" map. But I also found that the brush the zombies were spawning on were causing the issue.

Previously I had changed texture of the brush they were spawning on and recreated the solid in which they spawned on, but no luck. After porting everything into a new map and changing the solid they spawn on, it appears to be all working. Hopefully this helps anyone else having similar issue. I should note it was one of the grass textures, not sure if that matters or not.